#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[^local ]function (.*?)\("
Local $sString = "local function testing1( )" & @CRLF & _
" " & @CRLF & _
"end" & @CRLF & _
"" & @CRLF & _
"function testing2( ) -- matches on regex101, but not via MTA's pregs" & @CRLF & _
" " & @CRLF & _
"end" & @CRLF & _
" " & @CRLF & _
"addEventHandler( "test"," & @CRLF & _
" function( )" & @CRLF & _
" " & @CRLF & _
" end" & @CRLF & _
")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")