import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^local ]function (.*?)\\(";
final String string = "local function testing1( )\n"
+ " \n"
+ "end\n\n"
+ "function testing2( ) -- matches on regex101, but not via MTA's pregs\n"
+ " \n"
+ "end\n"
+ " \n"
+ "addEventHandler( \"test\",\n"
+ " function( )\n"
+ " \n"
+ " end\n"
+ ")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}