const regex = /^[^local ]function (.*?)\(/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^local ]function (.*?)\\(', 'gmi')
const str = `local function testing1( )
end
function testing2( ) -- matches on regex101, but not via MTA's pregs
end
addEventHandler( "test",
function( )
end
)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}