using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^local ]function (.*?)\(";
string input = @"local function testing1( )
end
function testing2( ) -- matches on regex101, but not via MTA's pregs
end
addEventHandler( ""test"",
function( )
end
)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}