package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[^local ]function (.*?)\(`)
var str = `local function testing1( )
end
function testing2( ) -- matches on regex101, but not via MTA's pregs
end
addEventHandler( "test",
function( )
end
)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}