use strict;
my $str = 'local function testing1( )
end
function testing2( ) -- matches on regex101, but not via MTA\'s pregs
end
addEventHandler( "test",
function( )
end
)';
my $regex = qr/^[^local ]function (.*?)\(/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}