$re = '/^[^local ]function (.*?)\(/mi';
$str = 'local function testing1( )
end
function testing2( ) -- matches on regex101, but not via MTA\'s pregs
end
addEventHandler( "test",
function( )
end
)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);