#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b((?:a1|a2|a3|a4)\*)(?=\b(?:a1|a2|a3|a4)\b)|\*"
Local $sString = "3*a1 + a1*a2 + 4*a3*a4 + a1*a3"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)