using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:a1|a2|a3|a4)\*)(?=\b(?:a1|a2|a3|a4)\b)|\*";
string substitution = @"\1";
string input = @"3*a1 + a1*a2 + 4*a3*a4 + a1*a3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}