import Foundation
let pattern = #"\b((?:a1|a2|a3|a4)\*)(?=\b(?:a1|a2|a3|a4)\b)|\*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"3*a1 + a1*a2 + 4*a3*a4 + a1*a3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)