re = /\b((?:a1|a2|a3|a4)\*)(?=\b(?:a1|a2|a3|a4)\b)|\*/
str = '3*a1 + a1*a2 + 4*a3*a4 + a1*a3'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result