$re = '/\b((?:a1|a2|a3|a4)\*)(?=\b(?:a1|a2|a3|a4)\b)|\*/';
$str = '3*a1 + a1*a2 + 4*a3*a4 + a1*a3';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;