# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)(^.*\.$|\([^()]*\)|if\(.*?\\/\\/endif)|\b\d+\b/$1/g;t' <<< "cat 123 sat.
I like 000 not (456) though 111 is fine
222 if( //endif if(cat==789 stuff //endif 333"