$re = '/(?m)(^.*\.$|\([^()]*\)|if\(.*?\/\/endif)|\b\d+\b/';
$str = 'cat 123 sat.
I like 000 not (456) though 111 is fine
222 if( //endif if(cat==789 stuff //endif 333';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;