import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(^.*\\.$|\\([^()]*\\)|if\\(.*?\\/\\/endif)|\\b\\d+\\b";
final String string = "cat 123 sat.\n"
+ "I like 000 not (456) though 111 is fine\n"
+ "222 if( //endif if(cat==789 stuff //endif 333";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}