import Foundation
let pattern = #"(?m)(^.*\.$|\([^()]*\)|if\(.*?\/\/endif)|\b\d+\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
cat 123 sat.
I like 000 not (456) though 111 is fine
222 if( //endif if(cat==789 stuff //endif 333
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)