package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^.*\.$|\([^()]*\)|if\(.*?\/\/endif)|\b\d+\b`)
var str = `cat 123 sat.
I like 000 not (456) though 111 is fine
222 if( //endif if(cat==789 stuff //endif 333`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}