#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^.*\.$|\([^()]*\)|if\(.*?\/\/endif)|\b\d+\b"
Local $sString = "cat 123 sat." & @CRLF & _
"I like 000 not (456) though 111 is fine" & @CRLF & _
"222 if( //endif if(cat==789 stuff //endif 333"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)