using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(^.*\.$|\([^()]*\)|if\(.*?\/\/endif)|\b\d+\b";
string substitution = @"$1";
string input = @"cat 123 sat.
I like 000 not (456) though 111 is fine
222 if( //endif if(cat==789 stuff //endif 333";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}