using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^""]*"")|(\S+)";
string substitution = @"$2";
string input = @"Some of ""this string is"" in quotes";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}