use strict;
my $str = 'Some of "this string is" in quotes';
my $regex = qr/("[^"]*")|(\S+)/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";