const regex = /("[^"]*")|(\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("[^"]*")|(\\S+)', 'g')
const str = `Some of "this string is" in quotes`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);