re = /("[^"]*")|(\S+)/
str = 'Some of "this string is" in quotes'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result