package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`("[^"]*")|(\S+)`)
var str = `Some of "this string is" in quotes`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}