$re = '/("[^"]*")|(\S+)/';
$str = 'Some of "this string is" in quotes';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;