import Foundation
let pattern = #"("[^"]*")|(\S+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Some of "this string is" in quotes"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)