#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[(]?(((\d)([() .-]+)?)+){7,15}|\*\d{3,10}|\d{3,10}\*"
Local $sString = "212-5551212" & @CRLF & _
"1-2-3-4-5-6-7-" & @CRLF & _
"(734) 555 1212" & @CRLF & _
"(734) 555.1212" & @CRLF & _
"(734) 555-1212" & @CRLF & _
"(734) 5551212" & @CRLF & _
"(734)5551212"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")