re = /[(]?(((\d)([() .-]+)?)+){7,15}|\*\d{3,10}|\d{3,10}\*/
str = '212-5551212
1-2-3-4-5-6-7-
(734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end