const regex = /[(]?(((\d)([() .-]+)?)+){7,15}|\*\d{3,10}|\d{3,10}\*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[(]?(((\\d)([() .-]+)?)+){7,15}|\\*\\d{3,10}|\\d{3,10}\\*', 'g')
const str = `212-5551212
1-2-3-4-5-6-7-
(734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}