// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[(]?(((\d)([() .-]+)?)+){7,15}|\*\d{3,10}|\d{3,10}\*").unwrap();
let string = "212-5551212
1-2-3-4-5-6-7-
(734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}