import Foundation
let pattern = #"[(]?(((\d)([() .-]+)?)+){7,15}|\*\d{3,10}|\d{3,10}\*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
212-5551212
1-2-3-4-5-6-7-
(734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)