package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[(]?(((\d)([() .-]+)?)+){7,15}|\*\d{3,10}|\d{3,10}\*`)
var str = `212-5551212
1-2-3-4-5-6-7-
(734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}