using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[(]?(((\d)([() .-]+)?)+){7,15}|\*\d{3,10}|\d{3,10}\*";
string input = @"212-5551212
1-2-3-4-5-6-7-
(734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}