#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*?)(\w{3})(((\+|-)\d{4}).*)"
Local $sString = "Sat Sep 12 2015 15:00:00 GMT+0100 (GMT Daylight Time)" & @CRLF & _
"Sat Sep 12 2015 15:00:00 GMT-0100 (GMT Daylight Time)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")