use strict;
my $str = 'Sat Sep 12 2015 15:00:00 GMT+0100 (GMT Daylight Time)
Sat Sep 12 2015 15:00:00 GMT-0100 (GMT Daylight Time)';
my $regex = qr/(.*?)(\w{3})(((\+|-)\d{4}).*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}