re = /(.*?)(\w{3})(((\+|-)\d{4}).*)/
str = 'Sat Sep 12 2015 15:00:00 GMT+0100 (GMT Daylight Time)
Sat Sep 12 2015 15:00:00 GMT-0100 (GMT Daylight Time)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end