const regex = /(.*?)(\w{3})(((\+|-)\d{4}).*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(\\w{3})(((\\+|-)\\d{4}).*)', 'g')
const str = `Sat Sep 12 2015 15:00:00 GMT+0100 (GMT Daylight Time)
Sat Sep 12 2015 15:00:00 GMT-0100 (GMT Daylight Time)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}