$re = '/(.*?)(\w{3})(((\+|-)\d{4}).*)/';
$str = 'Sat Sep 12 2015 15:00:00 GMT+0100 (GMT Daylight Time)
Sat Sep 12 2015 15:00:00 GMT-0100 (GMT Daylight Time)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);