package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?)(\w{3})(((\+|-)\d{4}).*)`)
var str = `Sat Sep 12 2015 15:00:00 GMT+0100 (GMT Daylight Time)
Sat Sep 12 2015 15:00:00 GMT-0100 (GMT Daylight Time)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}