import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(\\w{3})(((\\+|-)\\d{4}).*)";
final String string = "Sat Sep 12 2015 15:00:00 GMT+0100 (GMT Daylight Time)\n"
+ "Sat Sep 12 2015 15:00:00 GMT-0100 (GMT Daylight Time)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}