package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<input value="(\w*)" name="A3">`)
var str = `<input value="AAA" name="A1"> <input value="BBB" name="A2"> <input value="TEXT" name="A3">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}