$re = '/<input value="(\w*)" name="A3">/';
$str = '<input value="AAA" name="A1"> <input value="BBB" name="A2"> <input value="TEXT" name="A3">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);