// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<input value="(\w*)" name="A3">"#).unwrap();
let string = "<input value=\"AAA\" name=\"A1\"> <input value=\"BBB\" name=\"A2\"> <input value=\"TEXT\" name=\"A3\">";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}