import re
regex = re.compile(r"<input value=\"(\w*)\" name=\"A3\">")
test_str = "<input value=\"AAA\" name=\"A1\"> <input value=\"BBB\" name=\"A2\"> <input value=\"TEXT\" name=\"A3\">"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")