#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)((?<=^#BeginEntries\n).*?(?=\n#EndEntries$))"
Local $sString = "#BeginEntries" & @CRLF & _
"This is a test" & @CRLF & _
"#EndEntries" & @CRLF & _
""
Local $sSubst = "Success!"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)