import Foundation
let pattern = ##"(?s)((?<=^#BeginEntries\n).*?(?=\n#EndEntries$))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#BeginEntries
This is a test
#EndEntries
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Success!"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)