use strict;
my $str = '#BeginEntries
This is a test
#EndEntries
';
my $regex = qr/(?s)((?<=^#BeginEntries\n).*?(?=\n#EndEntries$))/mp;
my $subst = 'Success!';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";