re = /(?s)((?<=^#BeginEntries\n).*?(?=\n#EndEntries$))/m
str = '#BeginEntries
This is a test
#EndEntries
'
subst = 'Success!'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result