const regex = /(?s)((?<=^#BeginEntries\n).*?(?=\n#EndEntries$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)((?<=^#BeginEntries\\n).*?(?=\\n#EndEntries$))', 'gm')
const str = `#BeginEntries
This is a test
#EndEntries
`;
const subst = `Success!`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);