$re = '/(?s)((?<=^#BeginEntries\n).*?(?=\n#EndEntries$))/m';
$str = '#BeginEntries
This is a test
#EndEntries
';
$subst = "Success!";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;